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PDF Document Accessibility Test Process

Introduction

The use of Portable Document Formats (PDFs) is popular for sharing information. Unfortunately, persons with
disabilities, who utilize screen readers or other assistive technologies to read the content of PDFs, often cannot
access the content because the documents are not Section 508 compliant. To help ensure that 508 compliant
PDFs are disseminated, this test process has been created to evaluate documents against all applicable 1194.22
Web, 1194.24 Multimedia and 1194.31 Functional Performance Criteria standards.

Through the testing process, if an element is found to be Not Compliant, then the element remains Not
Compliant even if other elements are found to be Compliant. Marking an element Not Compliant will make the
document Not Compliant.

Accessibility Help Desk Information

For questions, and access to further resources including training, please review the Office of Accessible Systems
& Technology (OAST) intranet website or contact the DHS Accessibility Help Desk with any questions:

e OAST: http://dhsconnect.dhs.gov/org/comp/mgmt/cio/oast

e Accessibility Help Desk internal web site: Accessibility.DHS.gov

e Accessibility Help Desk: Accessibility@DHS.gov

Testing Tools

To validate PDFs for Section 508 compliance, testers must utilize the tools available in Adobe Acrobat
Professional to conduct manual and automatic Section 508 compliance testing. Adobe Acrobat Reader does not
include any accessibility validation tools and therefore it is not used to test PDFs in this test process.

Adobe Acrobat PDF Testing Tools:

Tool Location in

Testing Tool Description Tool location in Acrobat X
2 . Acrobat 7.0-9.0
Content Pane Displays the document’s content | View>Show/Hide>Navigation | View>Navigation
and its associated tags structure. | Panes>Content Panes>Content
Tags Pane Reveals the document’s tags tree | View>Show/Hide>Navigation | View>Navigation
and the properties associated Panes>Tags Panes>Tags

with the tags.

Order Pane Displays the document’s View>Show/Hide>Navigation | View>Navigation
reading/reflow order. Panes>Order Panes>Order

July 2012 | Version 1.0 Page|2
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Testing Tool

Description

Tool location in Acrobat X

Tool Location in
Acrobat 7.0-9.0

Show Page

Properties and displays the
form’s Tab Order.

Displays the document’s Reading | View>Show/Hide>Navigation | Order>Options>Show
Content Order Order/Reflow, identifies images Panes>0Order>Options>Show | Page Content Order
as having or not having Page Content Order
alternative text and reveals if a
table is tagged as a table.
Edit Reveals alternative text View>Tools>Content>Edit Tools>Advanced
Object\TouchUp associated with images. Object Editing>TouchUp
Object Object
Table Editor Displays table tags and tags View>Show/Hide>Navigation | Order Pane>Options>
properties. Panes>Order> Options> TouchUp Reading
TouchUp Reading Order Order>Table Editor
Panel>Table Editor
Form Editor Reveals form field’s tooltips via View>Tools>Forms>Edit Forms>Add/Edit Form

LiveCycle Designer
Accessibility Pane

Used only with forms created
with LiveCycle Designer, it
reveals form field’s tooltips and
displays the form’s Tab Order.

View>Tools>Forms>Edit or
from the Window’s Start
menu select All
Programs>Adobe LiveCycle
Designer

Forms>Add/Edit Form
or from the Window’s
Start menu select All
Programs>Adobe
LiveCycle Designer

Accessibility Full
Check

Adobe’s automated accessibility
checker.

Note: This is not a true Section
508 testing tool and must be
used in conjunction with a
manual test.

Tools>Accessibility>Full
Check

Advanced>
Accessibility>Full
Check

Read Out Loud

Read Out Loud is Adobe Acrobat’s simplified version of a document reader which can be used as an alternative

testing tool for reviewing a document’s reading order. This tool reads both the textual content of a PDF and tag

properties, such as alternative text for images and tooltips for form elements. However, the tool will not

announce tag attributes such as Header1, List or Paragraph. Additionally, some content may appear to read

twice because the content is presented in both the Content and Tags layer of the document. To access the Read
Out Loud tool, go to View>Read Out Loud>Activate Read Out Loud.

July 2012 | Version 1.0

Page|3




SERARTA

N Homeland PDF Document
Security Accessibility Test Process

PDF Accessibility Test Process

1. Editable Content and Interactive Elements

Editable content and interactive elements include selectable text, graphics, navigation elements, forms, button
controls, etc.

1.1. Content

Overview

PDFs are made up of three layers. The physical layer displays the visual appearance of the document. The
content layer reveals the document’s actual text and graphics; this layer is what is presented to assistive
technology and alternative devices such as smart phones. Lastly, the tags layer, similar to HTML tags, is used to
indicate page elements that define the document’s content structure and how elements relate to one another.
These elements include heading levels, paragraphs, tables, lists, graphics, and form elements to name a few.
Although a physical layer will always be presented in a PDF, some PDFs may not contain a content or tags layer.
Documents that do not contain these layers are not accessible and fail all applicable Section 508 standards and
Functional Performance Criteria.

Content

Graphical representations of textural content cannot be accessed by assistive technology; therefore, documents
must contain renderable text. By using the Content Pane, not only can you validate that the document contains
actual content, and can be used to tell how document elements are grouped via containers and tags. If content
is not contained within a container, or if the content is associated with an <Artifact> container, the content will
not be read by screen readers.

Tags

To help assistive technology users understand the visual layout of a document and how each section of the
document relates to one another, all documents must contain tags which map to document elements such as
Heading Levels, Paragraphs, List, Table, Table of Contents, Graphics, Links and Form elements, etc. Because PDF
tags can be generated by multiple applications, the tags naming convention may differ; however, all tags must
map to standard Acrobat PDF tags on page 23. To verify tags map to standard Acrobat PDF tags, view the tag’s
properties or view the Role Map. For a full list of PDF tags, see the appended list of Adobe Acrobat Standard
Tags List. It is not necessary to evaluate every single tag; however, when reviewing a sampling of tags pay close
attention to tags that should be associated with Heading Levels, Paragraphs, List, Tables, Graphics and Form
elements.

Note: In most cases, tags generated by applications outside of Acrobat use a tag naming convention similar to
the application’s styles and formatting options.

Reading Order

Documents must have a logical reading order. The Reading Order can be defined as reading from left to right,
top to bottom or in the order intended by the document’s author. A document that contains multi-column text,
tables, or call-out boxes adds a layer of complexity to the reading order and needs to be checked carefully. If
the reading order is defined in a non-logical order, screen readers may have difficulties understanding the
document’s content.

July 2012 | Version 1.0 Page|4
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Content How to Test Content Test Results

1

Use the Content Pane to verify the document contains
actual content and is not just a graphical representation
of content. Additionally, verify that repeated headers
and footers, page numbers and graphics that are for
decoration only are marked as Artifacts. These
elements do not need to be in the document’s reading
order.

Use the Tags Pane to verify that the document contains
tags that map to standard PDF tags and that each tag
accurately conveys the document’s visual
representation of styles and formatting, such as
Heading Levels, Paragraphs, Tables, Table of Content,
List, Graphics, Links and Form elements.

Use the Show Page Content Order tool to verify that the
document contains a logical reading order. The reading
order must be verified on each page of the document.

July 2012 | Version 1.0

If the document’s textual content is
not visible in the Content Pane, mark
22 (d) Not Compliant (NC) and end
test.

If the document is supposed to only
contain graphical content such as
charts and graphs, verify the
document is tagged as an image and
then proceed to Section 4.1 to test
the image.

If the document is not tagged,
mark22 (d) NC and end test,

If the document is tagged, but the
tags do not convey the document’s
visual structure, mark 22 (d) and 31
(a) and (b) as NC.

If the document does not contain a
logical reading order mark Web 22
(d), FPC 31 (a) and (b) as NC.

If non artifact content is not
contained in the document’s reading
order, mark Web 22 (d), FPC 31 (a)
and (b) as NC.

If artifact content is not marked as an
artifact, mark Web 22 (d), FPC 31 (a)
and (b) as NC.

If the document contains renderable
content, is properly tagged and has a
logical reading order, mark Web 22
(d), FPC 31 (a) and (b) as C.

Applicable 508 Standards:

1194.22 Web (d)
1194.31 FPC (a)
1194.31 FPC (b)

Page|5
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1.2. Fillable Form Elements

Overview

Fillable forms contain form elements such as Text boxes, List boxes, Dropdown boxes, Check boxes, Radio
buttons, Signature boxes, Barcodes and Buttons. These form elements can be created either by way of Acrobat
Form Editing tools or with LiveCycle Designer, a tool that comes with Acrobat Professional.

It is important to identify how a form was created, so that the correct test process can be conducted. To
determine how the form was created go to File>Properties>Description>Application.

Forms Created Using Acrobat Editing tools

All form elements must be tagged as <Form>, contain tooltips and have a logical Tab Order, so that they can be
accessed by screen readers. Forms may have extended features for Acrobat Reader turned on which does not
impact accessibility but it does restrict functionality in Acrobat Professional and prevents the ability to
accurately test the form for Section 508 compliance. Go to File>Properties>Security and see if Creation of
Template Page is “Not allowed.” If so, extended features for Acrobat Reader is turned on. To create a version
of the form that can be tested, go to File>Save a Copy to create a copy of the form for testing.

Forms Created Using LiveCycle Designer

Although dynamic LiveCycle PDF forms do not contain tags, they can still be accessible as long as they contain
descriptive tooltips and have a logical Tab Order. Because LiveCycle Designer is not fully integrated into Acrobat
Professional, LiveCycle forms must be tested using the Accessibility Pane located in LiveCycle Designer. To
access the Accessibility Pane, select the form element and then from the Windows menu select Accessibility.

Tooltips

Much like alternative text for images, tooltips provide a descriptive narrative for form elements that provide
information that is conveyed both via visual layout and form field label. Because screen readers only announce
the tooltip when tabbing to a form element, check boxes and radio buttons’ tooltips must contain both the
guestion and form field’s label as part of the tooltip.

Tab Order
Electronic forms must contain a logical Tab Order. If the Tab Order randomly jumps around the screen or

navigates the user through the form in an illogical manner, the user may not be able to fill out the form
correctly.

July 2012 | Version 1.0 Page|6
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Forms How to Test Forms Test Results

1

Forms created using Acrobat Form Editing tools
Use the Tags Pane to verify all form elements are
tagged as <Form>.

Forms created using LiveCycle Forms

Do not require tags for accessibility.

Forms created using Acrobat Form Editing tools

Mouse over form elements to view the tooltip or view
the form element’s properties by activating the Form
Edit tool and then select the form element, right click
the form element and select
Properties>General>Tooltip to validate tooltips.

Forms created using LiveCycle Forms

Mouse over form elements to view the tooltip or access
the Accessibility Pane in LiveCycle Designer to view
Form element tooltips to validate tooltips.

Forms created using Acrobat Form Editing tools

Press the Tab key or view the Tab Order tree located in
the Form Editing tool to validate that the form has a
logical Tab Order.

Forms created using LiveCycle Forms

Press the Tab key to validate that the form contains a
logical Tab Order.

If form elements are not tagged as
<Form>, mark Web 22 (n), FPC 31
(a), (b)and (f) as NC. Note: This
check is not applicable for
LiveCycle forms.

If form elements do not contain
descriptive tooltips, mark Web 22
(n), FPC 31 (a), (b) and (f) as NC.

If form elements do not appear in
a logical tab order, mark PFC 31
(a), (b) and (f) as NC.

If form elements are tagged as
<Form>, have a descriptive tooltip
and appears in a logical tab order,
mark Web 22 (n), FPC 31 (a), (b)
and (f) as C.

July 2012 | Version 1.0

Applicable 508 Standards:

1194.22 Web (n)
1194.31 FPC (a)
1194.31 FPC (b)
1194.31 FPC (f)

Page|7



ARTAs
oEle

Homeland
Security

Y a0 Y

-

sl t".s_

)
)

)
7 &
AND G-

PDF Document

Accessibility Test Process

1.3. Language

Overview

The language selected in the document’s properties defines if content should be read from left to right or right
to left, and it is also used by screen readers to select the correct language synthesizer to read the document. If
the wrong language is set, screen readers may pronounce the content incorrectly. If the document contains
multiple languages, the language must not only be set in the document’s properties, but also in the tag’s
properties related to the block of content where the language has changed. The document’s language
properties settings supersede all language settings unless defined in the tags properties.

Language How to Test Language Test Results

1 Select File>Properties>Advanced>Language to view the
document’s language setting and confirm that the
document’s native language has been set to the correct
language.

2 Visually scan the document to determine if the
document contains multiple languages and if so, locate
the tag associated with the content and view the
language properties by right clicking on the tag and
selecting Properties>Tag>Language to verify the
appropriate language has been set.

July 2012 | Version 1.0

If the document’s language
property is not set to the
document’s native language,
mark FPC 31 (a) and (b) as NC.

If the language changes within
the document and the language is
not set in the tag’s properties
mark FPC 31 (a) and (b) as NC.

If the document’s language
property is set correctly, mark
FPC 31 (a) and (b) as C.

Applicable 508 Standards:

1194.31 FPC (a)
1194.31 FPC (b)

Page|8
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2. Color Dependence

Overview

Information provided by way of color must also be available in an alternate method. Color cannot be the only
method to indicate an action, prompt a response or emphasize text. Examples of inappropriate use of color are:
the red fields are required, yellow items should be selected first, or green fields can be ignored. Additionally,
when color is used in a document, there must be a strong contrast between the foreground and background.

Color Dependence How to Test

1 Conduct a visual inspection to see if color is used within
the document and first discern if it is used to convey
information, and then determine if a textual equivalent
is required.

2 | Select Edit>Preferences>Accessibility>Replace

Document Colors>Use High Contrast Colors to view the
document in high contrast. Once in High Contrast, view
the entire document to confirm content does not
disappear or become difficult to view.

July 2012 | Version 1.0

Color Dependence Test Results

If information is provided only
through color, mark Web 22 (c),
FPC 31 (a) and (b) as NC.

If information is provided by color
and indicated in an alternative
method, mark Web 22 (c), F

PC 31 (a) and (b) as C.

If content is not viewable or
difficult to see due to poor
contrast mark FPC 31(a) and (b) as
NC.

If all content is easy to read when
viewed in High Contrast mark FPC
31 (a) and (b) as C.

If color is not used to convey
information, prompt a response,
or indicate an action, mark Web
22 (c), FPC 31 (a) and (b) as NA.

Applicable 508 Standards:

1194.22 Web (c)
1194.31 FPC (a)
1194.31 FPC (b)

Page|9
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3. Data Tables \

Overview

Documents may contain both data tables and tables for layout purposes. Do not check layout tables; this
standard applies to data tables ONLY. Data tables can be identified by a data cell that requires a row or column
header to describe the cell information. For example, if only reading the cell contents does not provide
sufficient information to understand the full context, it requires mark up and is not a layout table.

Simple Data Tables

Simple data tables contain one row of Column Headers.

Complex Data Tables
Complex Data Tables contains two or more rows of Column Headers and may also contain merged or split data
cells.
Using the Table Editor Tool to validate Data Tables
To setup the Table Editor tool so that the properties of data tables can be viewed, do the following:
1. Select Order Pane>Options>Show Reading Order Pane.
2. Select the Order number associated with the tagged data table.

3. Select Table Editor on the Show Reading Order Pane tool. If the Table Editor button is not activated, the
data table is not selected. Once the button is selected, the data table will be highlighted with a table
grid.

4. Right click a data cell and select Show Table Editor Options to set up options to view Table Header and
Table Data cells. Once these options are set, they will not need to be set again.

5. Right click a data cell and select Table Cell Properties to view properties related to the data cell.

July 2012 | Version 1.0 Page|10
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Data Tables How to Test

1

Use the Table Editor tool or the Tags Pane to visually
verify the data table has a logical reading order. All data
table elements must be contained in individual data
cells and be organized in the same way as the table
layout.

Use the Table Editor tool to confirm all Column and/or
Row headers are associated with <TH> tags

Use the Table Editor tool to verify all table cells, with
the exception of those associated with the <TH> tags,
are designated as <TD> Table Data Cells.

Visually determine if the data table is simple or
complex. If the table is a complex table, check to see if
it has scope applied to the appropriate Row/Column
Headers.

Use the Table Editor tool to verify that data cells in the
tables are associated with the Row/Column Header
elements.

July 2012 | Version 1.0

Data Table Test Results

If the data table does not have the
correct reading order mark Web
22 (d) as NC.

If a data table does not have all
Row or Column headers
identified, mark Web 22 (g) as NC.

If a complex data table does not
have scope associated with
Column and or Row headers mark
Web 22 (h) as NC.

If the simple table has a logical

reading order and all data table
headers and cells are identified
properly, mark Web 22 (g) as C.

If all complex data table cells are
associated properly, mark Web 22
(h) as C.

If there are no complex data
tables, mark Web 22 (h) as NA.

If there are no data tables, mark
22 (g) and Web 22 (h) as NA.

Applicable 508 Standards:

1194.22 Web (d)
1194.22 Web (g)
1194.22 Web (h)

Page|11
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4. Non-Textual Elements

Figures, images, animations, graphs, and audio files must have equivalent descriptions for screen reader users.
Multimedia files require synchronized captioning and audio descriptions when information is conveyed visually
only.

4.1. Images, Pictures, Objects etc

Overview

Images, Pictures, Objects etc:

ALL images that convey information must contain an alternate text attribute which can be read by screen
readers.

e Images that convey information must provide an equivalent description in the form of alternative text. If
images contain text that conveys key information, the text must also be represented in the alternative
text. For example the alternative text description for the DHS seal should be “Department of Homeland
Security seal.”

e Images that do not convey information such as decorative images should be marked as Artifacts so that
they are not announced by a screen reader.

e Signatures and handwritten images should be tagged as an image with descriptive Alternative Text.

Charts, Graphical representations of data:

e [fthe chartis intended only to show a trend, the alternative text should contain a description of the
trend.

e Charts that contain greater detail should include a compliant data table with the chart’s source data.

e Alternative text for complex charts, graphs and decision charts should contain office contact
information so that individuals that need additional assistance understanding the graphics can receive
the help he/she needs.

July 2012 | Version 1.0 Page|12
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Images How to Test Image Test Results

1 Use the Edit Object/TouchUp Object tool or view the
properties of the tag associated with the image to verify
that the image contains descriptive alternative text.

2 Visually identify complex images and determine if a
reference to a more detailed text description is needed
and has been provided.

3 Use the Content Pane to verify all decorative images are
marked as <Artifact>.

July 2012 | Version 1.0

If an image does not have an
equivalent text description, mark
Web 22 (a), FPC 31 (a) and (b) as
NC.

If a decorative image is not
marked as an <Artifact> or does
not contain alternative text, mark
22 Web (a), FPC 31 (a) and (b) as
NC.

If all images have an equivalent
text description, mark Web 22 (a),
FPC 31 (a) and (b) as C.

If decorative images are marked
as <Artifacts> mark Web 22 (a),
FPC 31 (a) and (b) as C.

If the document contains no
images, mark Web 22 (a), FPC 31
(a) and (b) as NA.

Applicable 508 Standards:

1194.22 Web (a)
1194.31 FPC (a)
1194.31 FPC (b)

Page|13
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4.2. Audio-only and Video-only Files

Overview

Audio or video only files must be accompanied with an accurate text equivalent. Audio files only play audible
words or sounds and are considered non-text interface elements. Video files that only display visual
information are also considered non-text interface elements. Both file types require equivalent text
descriptions to describe the content. Usually, this is a transcript for audio-only files. For video files with no
sound, a description of the content is sufficient.

Audio or Video Players
Software players must meet 1194.21 Software standards. For assistance testing the software player for Section

508 compliance contact the Accessibility Helpdesk at Accessibility.DHS.gov or via
e-mail at Accessibility@dhs.gov.

July 2012 | Version 1.0 Page|14
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Audio or Video How to Test Audio or video Test Results
1 | Visually check to see if the document contains an audio e If an audio interface element does
file. If so verify it includes a text description that not have an equivalent text
includes all relevant audio cues (ex: door bell rings, car transcript mark Web 22 (a),
honks, etc.)? If a text description is available, read the FPC 31 (c) and (d) as NC.

text description while listening to the audio file to

. oo o Ifvideo interface elements do not
ensure all necessary information is captured.

have an equivalent audio

2 | Visually check the document to see if it contains a video description mark Web 22 (a),
file. If so, verify that it includes a text description which FPC 31 (a), (b) as NC.
includes all visual cues (ex: driver hands license to
officer). If a text description is available, read the text
description while watching the video file to ensure all
necessary information is captured.

e If the target for the audio and/or
video file is not tagged mark
Web 22 (d), FPC 31 (a), (b), (c) and
(d) as NC.

3 | Verify that the target is tagged.

e Ifall audio and video interface
elements have an equivalent text
(transcript), or video-description
and the target for the audio
and/or video file is tagged mark
Web 22 (a), (d), FPC 31 (a), (b), (c)
and (d) asC.

e If the content is text only, mark
Web 22 (a), FPC 31 (a), (b), (c) and
(d) as NA.

Applicable 508 Standards:

1194.22 Web (a)
1194.22 Web (d)
1194.31 FPC (a)
1194.31 FPC (b)
1194.31 FPC (c)
1194.31 FPC (d)

July 2012 | Version 1.0 Page|15
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4.3. Multimedia

Overview

Multimedia Players

Multimedia is the combination of more than one time-based medium including visuals and sound to match at
the same rate and exactly together to convey information and instruction. All multimedia presentations must
contain captioning for auditory information and audio descriptions for information conveyed visually only.

Multimedia players must meet 1194.21 Software standards. For assistance testing the multimedia player for
Section 508 compliance contact the Accessibility Helpdesk at Accessibility.DHS.gov or via

e-mail at Accessibility@dhs.gov.

Multimedia How to Test: Multimedia Test Results

1 | Visually inspect the document for multimedia. If the
document contains multimedia, manually check the
multimedia for captioning that is synchronized with the
audible sounds and dialogue. Descriptions of important
sounds must be included in captions. If there are visual
actions necessary for comprehension, check that they
are adequately described in the audio track. All relevant
audible and visual information from the multimedia
should be available if the speakers are off or if the
monitor is off.

July 2012 | Version 1.0

e If there are no synchronized
captions, mark Web 22 (b) and 24
(c) as NC.

e |f audio descriptions are needed
and not provided, mark Web 22
(b) and 24 (d) as NC.

e If the multimedia includes
synchronized captions and audio
descriptions, mark Web 22 (b), 24
(c) and (d) as C.

e If there is no multimedia, mark
Web 22 (b), 24 (c) and (d) as NA.

Applicable 508 Standards:

1194.22 Web (b)
1194.24 Multimedia (c)

1194.24 Multimedia (d)
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Overview

Although security settings can be set to protect a document from being modified, security settings must never
prevent assistive technology from being able to read a document.

Security How to Test Security Test Results
1 | Goto File>Properties>Security> and check to see if e If Content Copying for Accessibility is
Content Copying for Accessibility is “Allowed”. not allowed mark FPC 31 (a) and (b) as

NC.

e If Content Copying for Accessibility is
allowed mark FPC 31 (a) and (b) as C.

Applicable 508 Standards:

1194.31 FPC (a)
1194.31 FPC (b)

July 2012 | Version 1.0 Page|17



PARTY

% . Homeland PDF Document
< Security Accessibility Test Process

0

WU

‘;\O
Y

)

oy o
LiNp 5o

6. Accessible Version

Overview

Alternative versions for accessibility are only permitted when the primary content cannot be made compliant.

Check for a Text only or alternative version of content:
e If the primary content is not compliant but can be made compliant, then it must be remediated.
o Text only files must be maintained and updated with the primary content.

Note: PDFs created via Flash Paper cannot be made compliant. Decision charts may require a text alternative.

Accessible Version How to Test Accessible Version Test Results

1 Manually verify that the primary content cannot be e If there is no alternative
made accessible. Verify that the text only or alternative version(s), mark Web 22 (k) as NA.
version contains identical information as the primary

o If the primary document can be
made compliant, mark Web 22 (k)
as NC.

source.

o If the alternative accessible
version is not compliant, mark
Web 22 (k) as NC. The alternative
version must be fully tested.

e If the primary content cannot be
made accessible, and the
alternative version contains
equivalent accessible information,
mark Web 22 (k) as C.

Applicable 508 Standards:

1194.22 Web (k)

July 2012 | Version 1.0 Page|18
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Adobe Acrobat Accessibility Full Check Tool

The Accessibility Full Check tool can help to identify areas of a document that may be in conflict with Adobe’s
interpretations of accessibility guidelines, such as the document lacking actual text, a specified language and
having security settings that prevents access by screen readers. However, the tool does not check documents
against all accessibility criteria. Therefore, Acrobat’s Accessibility Full Check tool must be used in conjunction
with a manual testing process to correctly evaluate PDFs for Section 508 compliance.

How to Set Up Accessibility Full Check Tool

1. Go to Tools>Accessibility>Full Check to access the Accessibility Full check tool.
2. Under Reports and Comments Options check
a. Create Accessibility Report
b. Include repair hints in Accessibility Report
3. Under Page Range select
a. All pagesin document
4. Under Checking Options select
a. (Name) Acrobat PDF
b. Alternative descriptions are provided
c. Textlanguage is specified
d. Reliable character encoding is provided
e. All content is contained in the document structure
f.  All form fields have descriptions
g. Tab order is consistent with the structure order
h. List and Table structure is correct

5. Select Start Checking to run the Accessibility Full Check tool

What does the Accessibility Full Check Tool Do?
This tool allows users to quickly identify the following issues:

e |f the document does or does not contain tags

e If alanguage has been set in the document’s properties

e [f content is not tagged

e Ifthe font in the document is related to reliable character encoding
e [f the tab order is consistent with the documents structure.

e |[f alternative text has been applied to images

e If tooltips have been applied to form fields
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e [flist and tables have a correct tag structure

What are the limitations of the Full Check Tool?
Elements that the tool cannot accurately evaluate for Section 508 compliance includes but is not limited to:
e Validating if all of the content is contained in the structure tree and follows a logical Reading and Tab
order
e Validating if Color alone is not being used to convey information
e Validating if images contain accurate alternative text descriptions
e Validating if form fields are associated with proper tooltips

Additionally, the Accessibility Full Check tool may also generate Acrobat structure errors that are unrelated to
Section 508. These errors include, but are not limited to:

e Unspecified Unicode- Acrobat does not recognize the font type used in the document

e Untagged Annotations- Meta data in Microsoft Office was not cleared before converting the document
into a PDF

e Inaccessible Link- At this time it is unknown why Acrobat generates this error
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List of Acrobat Full Check Errors

Source: The information located under the “Meaning” column was taken from the Social Security

Administration’s draft guidance for testing PDFs, April 2012. Used with permission.

Figure element(s)
with no alternate
text

Figures (pictures, images) do not have any alternate text added.

Note: This check does not account for the following, which must
be checked manually:

1. Images that contain alternate text that is insufficient for
a reader to comprehend the purpose of the image,
and/or alternate text that is incorrect, or not helpful in
the context of the surrounding image.

2. Images that contain paths or filenames in place of
correct alternate text.

3. Images that are part of the background
(i.e., purposefully have no alternate text) will be
incorrectly flagged as errors by this test.

36 CFR 1194.22(a)
36 CFR 1194.31(a)

36 CFR 1194.31(b)

All of the text on this
page lacks a
language
specification

The default language has not been set in the document
properties.

Note: This checks only that there is a language specified; it does
not check whether the correct language is specified.

36 CFR 1194.31(a)

36 CFR 1194.31(b)

Word(s) that contain
characters with no
reliable mapping to
Unicode

This is error occurs when non-standard fonts are used, either for
the whole document, chunks of text, or bullet characters. Screen
reader software will typically not pronounce these correctly.

Note: The fonts that are erroneous can be easily inspected, as
errors are clearly annotated in the Document Properties Panel
(Fonts tab).

36 CFR 1194.31(a)

36 CFR 1194.31(b)

Element(s) that are
not contained within
the structure tree

This error means there are elements on the page for which
there is no corresponding tag.

This error usually occurs if an element has been added to an
existing PDF using Acrobat’s editing tools (e.g., a link or an image
is added). In the editing process, tags are not automatically
added.

36 CFR 1194.22(d)

July 2012 | Version 1.0

Page|21




ARTps
oEle

@ Homeland
7 Security

PDF Document
Accessibility Test Process

None of the
comments or other
types of annotations
on this page are
contained in the
structure tree

This error usually occurs if a comment has been added to an
existing PDF using Acrobat’s editing tools. In the editing process,
tags are not automatically added.

Note: If in running the ‘Accessibility Full Check’ dialog box the
reviewer has selected ‘Create comments in the document’, and
then the check is run a subsequent time, the checker’s own
comments will generate this error.

If this error occurs, but the document is intended for an
audience that is relying on editorial comments and tracking for
its work, then the error can be ignored. However, if there are
Assistive Technology users working with the document, then
additional verification tasks may be needed to determine
whether the comments and other annotations are accessible.

36 CFR 1194.22(d)

Form field(s) with no
description

This error will only occur when form fields are used.

36 CFR 1194.22(n)

Page(s) with tab
order that may be
inconsistent with the
structure order

This error will only occur when form fields are used.

36 CFR 1194.31(a)

36 CFR 1194.31(b)

Tab order may be
inconsistent with the
structure order

This error occurs when the Page Tab Order is set to something
other than “Use Document Structure”

36 CFR 1194.31(a)
36 CFR 1194.31(b)

List tags/item(s) with
no parent(s)

The correct list tagging structure has not been used.

Note: This automated test does not check for chunks of text that
should be marked as lists but which is actually formatted as
regular paragraph text. Lists formatted as regular paragraph
text must be checked manually.

36 CFR 1194.22(d)

TH or TD element(s)
with no TR parent

This error occurs if table tags have been edited incorrectly in
Acrobat (e.g., moved around in the tag tree, where they are
outside of the normal table tag structure).

Note: This automated test does not check for tables that have no
tags, have incorrect tags, or tables that are rendered as images.
Tables that are irregularly formatted, and tables that are not
tagged, must be checked manually.

36 CFR 1194.22(d)

Other errors

Other errors may be generated. Follow on-screen instructions
for more details.

Note: The above lists the common errors that can be generated
by the Adobe Acrobat X Accessibility Checker at the time of
writing. Future software updates may alter the checker’s results.

N/A

July 2012 | Version 1.0
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Standard Acrobat PDF Tags

Source: Excerpted from Adobe Systems, Inc. (2011) Using Adobe Acrobat X Pro, (pp.301-303), Adobe Systems
Incorporated, 345 Park Avenue, San Jose, California 95110, USA. Available:
http://help.adobe.com/en US/acrobat/pro/using/acrobat X pro_help.pdf

Container Elements

Container elements are the highest level of element and provide hierarchical grouping for other block-level
elements.

Document
Document element. The root element of a document’s tag tree.

Part
Part element. A large division of a document; may group smaller units of content together, such as division
elements, article elements, or section elements.

Div
Division element. A generic block-level element or group of block-level elements.

Art
Article element. A self-contained body of text considered to be a single narrative.

Sect
Section element. A general container element type, comparable to Division (DIV Class="Sect") in HTML, which is
usually a component of a part element or an article element.

Heading and Paragraph Elements

Heading and paragraph elements are paragraph-like, block-level elements that include specific level heading
and generic paragraph (P) tags. A heading (H) element should appear as the first child of any higher-level
division. Six levels of headings (H1 to H6) are available for applications that don’t hierarchically nest sections.

Label and List Elements
Label and list elements are block-level elements used for structuring lists.
L

List element. Any sequence of items of similar meaning or other relevance; immediate child elements should be
list item elements.

LI
List item element. Any one member of a list; may have a label element (optional) and a list body element
(required) as a child.
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LBL
Label element. A bullet, name, or number that identifies and distinguishes an element from others in the same
list.

LBody
List item body element. The descriptive content of a list item.

Special Text Elements
Special text elements identify text that isn’t used as a generic paragraph (P).
BlockQuote

Block quote element. One or more paragraphs of text attributed to someone other than the author of the
immediate surrounding text.

Caption
Caption element. A brief portion of text that describes a table or a figure.

Index
Index element. A sequence of entries that contain identifying text and reference elements that point out the
occurrence of the text in the main body of the document.

TOC
Table of contents element. An element that contains a structured list of items and labels identifying those items;
has its own discrete hierarchy.

TOCI
Table of contents item element. An item contained in a list associated with a table of contents element.

Table Elements
Table elements are special elements for structuring tables.
Table

Table element. A two-dimensional arrangement of data or text cells that contains table row elements as child
elements and may have a caption element as its first or last child element.

TR
Table row element. One row of headings or data in a table; may contain table header cell elements and table
data cell elements.

D
Table data cell element. A table cell that contains nonheader data.

TH
Table header cell element. A table cell that contains header text or data describing one or more rows or columns
of a table.
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Inline-level Elements

Inline-level elements identify a span of text that has specific formatting or behavior. They are differentiated
from block-level elements. Inline-level elements may be contained in or contain block-level elements.
BibEntry

Bibliography entry element. A description of where some cited information may be found.

Quote

Quote entry element. An inline portion of text that is attributed to someone other than the author of the text
surrounding it; different from a block quote, which is a whole paragraph or multiple paragraphs, as opposed to
inline text.

Span
Span entry element. Any inline segment of text; commonly used to delimit text that is associated with a set of
styling properties.

Special Inline-level Elements

Similar to inline-level elements, special inline-level elements describe an inline portion of text that has special
formatting or behavior.

Code

Code entry element. Computer program text embedded within a document.

Figure
Figure entry element. A graphic or graphic representation associated with text.

Form
Form entry element. A PDF form annotation that can be or has been filled out.

Formula
Formula entry element. A mathematical formula.

Link
Link entry element. A hyperlink that is embedded within a document. The target can be in the same document,
in another PDF document, or on a website.

Note
Note entry element. Explanatory text or documentation, such as a footnote or endnote, that is referred to in the
main body of text.

Reference
Reference entry element. A citation to text or data that is found elsewhere in the document.
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Section 508 Standards Mapped to DHS PDF Document Test Process

Each Section 508 standard is mapped to the DHS PDF Testing Process for testers who are more familiar with the
alphabetical approach. Only the standards that are applicable to PDFs are listed. For a full list of the Section 508
standards of the Rehabilitation Act of 1973, as amended (29 U.S.C., go to Seciton 508 standards
(http://section508.gov/index.cfm?fuseAction=stdsdoc)

1194.22 Web

Standard ‘ Test Process

(a) Images

A text equivalent for every non-text element shall be provided (e.g., via "alt", "longdesc", or in
element content).

(b) Multimedia
Presentations

Equivalent alternatives for any multimedia presentation shall be synchronized with the
presentation.

(c) Color

Web pages shall be designed so that all information conveyed with color is also available
without color, for example from context or markup.

(d) Readability

Original Access-Board standard:
Documents shall be organized so they are readable without requiring an associated style
sheet.

Modified for PDFs:

The Content and Tag views should be consistent with the physical view, meaning that the
document should be read from the structure without requiring the physical view.

Note: This modified language was provided by NetCentric.

(g) Data Table

Row and column headers shall be identified for data tables.

(h) Data
Tables with
multiple
headers

Markup shall be used to associate data cells and header cells for data tables that have two or
more logical levels of row or column headers.

(k) Text-Only
Alternative

A text-only page, with equivalent information or functionality, shall be provided to make a web
site comply with the provisions of these standards, when compliance cannot be accomplished
in any other way. The content of the text-only page shall be updated whenever the primary
page changes.

(n) Electronic
Forms

When electronic forms are designed to be completed on-line, the form shall allow people using
assistive technology to access the information, field elements, and functionality required for
completion and submission of the form, including all directions and cues.

July 2012 | Version 1.0 Page|26


http://section508.gov/index.cfm?fuseAction=stdsdoc

oMU
5 _.rl ;
(4¢)
Y }'%

Homeland PDF Document
"7 Security Accessibility Test Process

1194.24 Multimedia

Standard

Test Process

(c)

Multimedia that contains speech or other audio information necessary for the comprehension of

Captioning | the content shall be open or closed captioned and the captioning must be synchronized and
spelled correctly.

(d) Audio All training and informational video and multimedia productions which support the agency's

Description | mission, regardless of format, that contain visual information necessary for the comprehension of

the content, shall be audio described.

1194.31 Functional Performance

Standard Test Process

(a) Blind

At least one mode of operation and information retrieval or support for assistive
technology shall be provided that does not require:

(b) Low Vision

At least one mode of operation and information retrieval or support for assistive
technology shall be provided that does not require:

(c) Deaf

At least one mode of operation and information retrieval or support for assistive
technology shall be provided that does not require:

(d)Hard of Hearing | At least one mode of operation and information retrieval or support for assistive

technology shall be provided that does not require:

(f) Mobility

At least one mode of operation and information retrieval that does not require fine motor
control or simultaneous actions and that is operable with limited reach and strength shall
be provided.
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	Forms How to Test 
	Forms How to Test 

	1 
	1 
	Forms created using Acrobat Form Editing tools Use the Tags Pane to verify all form elements are tagged as <Form>. Forms created using LiveCycle Forms Do not require tags for accessibility. 

	2 
	2 
	Forms created using Acrobat Form Editing tools Mouse over form elements to view the tooltip or view the form element’s properties by activating the Form Edit tool and then select the form element, right click the form element and select Properties>General>Tooltip to validate tooltips. Forms created using LiveCycle Forms Mouse over form elements to view the tooltip or access the Accessibility Pane in LiveCycle Designer to view Form element tooltips to validate tooltips. 

	3 
	3 
	Forms created using Acrobat Form Editing tools Press the Tab key or view the Tab Order tree located in the Form Editing tool to validate that the form has a logical Tab Order. Forms created using LiveCycle Forms Press the Tab key to validate that the form contains a logical Tab Order. 


	Forms Test Results 
	Forms Test Results 
	Forms Test Results 

	 If form elements are not tagged as <Form>, mark Web 22 (n), FPC 31 (a), (b) and (f) as NC. Note: This check is not applicable for LiveCycle forms.  If form elements do not contain descriptive tooltips, mark Web 22 (n), FPC 31 (a), (b) and (f) as NC.  If form elements do not appear in a logical tab order, mark PFC 31 (a), (b) and (f) as NC.  If form elements are tagged as <Form>, have a descriptive tooltip and appears in a logical tab order, mark Web 22 (n), FPC 31 (a) , (b) and (f) as C. 
	 If form elements are not tagged as <Form>, mark Web 22 (n), FPC 31 (a), (b) and (f) as NC. Note: This check is not applicable for LiveCycle forms.  If form elements do not contain descriptive tooltips, mark Web 22 (n), FPC 31 (a), (b) and (f) as NC.  If form elements do not appear in a logical tab order, mark PFC 31 (a), (b) and (f) as NC.  If form elements are tagged as <Form>, have a descriptive tooltip and appears in a logical tab order, mark Web 22 (n), FPC 31 (a) , (b) and (f) as C. 

	Applicable 508 Standards: 
	Applicable 508 Standards: 

	1194.22 Web (n) 1194.31 FPC (a) 1194.31 FPC (b) 1194.31 FPC (f) 
	1194.22 Web (n) 1194.31 FPC (a) 1194.31 FPC (b) 1194.31 FPC (f) 



	Artifact
	1.3. Language Overview The language selected in the document’s properties defines if content should be read from left to right or right to left, and it is also used by screen readers to select the correct language synthesizer to read the document. If the wrong language is set, screen readers may pronounce the content incorrectly. If the document contains multiple languages, the language must not only be set in the document’s properties, but also in the tag’s properties related to the block of content where 
	Artifact
	2. Color Dependence Overview Information provided by way of color must also be available in an alternate method. Color cannot be the only method to indicate an action, prompt a response or emphasize text. Examples of inappropriate use of color are: the red fields are required, yellow items should be selected first, or green fields can be ignored. Additionally, when color is used in a document, there must be a strong contrast between the foreground and background. Color Dependence How to Test 1 Conduct a vis
	Artifact
	3. Data Tables 
	3. Data Tables 
	3. Data Tables 

	Overview Documents may contain both data tables and tables for layout purposes. Do not check layout tables; this standard applies to data tables ONLY. Data tables can be identified by a data cell that requires a row or column header to describe the cell information. For example, if only reading the cell contents does not provide sufficient information to understand the full context, it requires mark up and is not a layout table. Simple Data Tables Simple data tables contain one row of Column Headers. Comple
	Overview Documents may contain both data tables and tables for layout purposes. Do not check layout tables; this standard applies to data tables ONLY. Data tables can be identified by a data cell that requires a row or column header to describe the cell information. For example, if only reading the cell contents does not provide sufficient information to understand the full context, it requires mark up and is not a layout table. Simple Data Tables Simple data tables contain one row of Column Headers. Comple


	Artifact
	Data Tables How to Test 
	Data Tables How to Test 
	Data Tables How to Test 
	Data Tables How to Test 

	1 
	1 
	Use the Table Editor tool or the Tags Pane to visually verify the data table has a logical reading order. All data table elements must be contained in individual data cells and be organized in the same way as the table layout. 

	2 
	2 
	Use the Table Editor tool to confirm all Column and/or Row headers are associated with <TH> tags 

	3 
	3 
	Use the Table Editor tool to verify all table cells, with the exception of those associated with the <TH> tags, are designated as <TD> Table Data Cells. 

	4 
	4 
	Visually determine if the data table is simple or complex. If the table is a complex table, check to see if it has scope applied to the appropriate Row/Column Headers. 

	5 
	5 
	Use the Table Editor tool to verify that data cells in the tables are associated with the Row/Column Header elements. 


	Data Table Test Results  If the data table does not have the correct reading order mark Web 22 (d) as NC.  If a data table does not have all Row or Column headers identified, mark Web 22 (g) as NC.  If a complex data table does not have scope associated with Column and or Row headers mark Web 22 (h) as NC.  If the simple table has a logical reading order and all data table headers and cells are identified properly, mark Web 22 (g) as C.  If all complex data table cells are associated properly, mark Web
	1194.22 Web (d) 1194.22 Web (g) 1194.22 Web (h) 

	Artifact
	4. Non‐Textual Elements 
	4. Non‐Textual Elements 
	4. Non‐Textual Elements 

	Figures, images, animations, graphs, and audio files must have equivalent descriptions for screen reader users. Multimedia files require synchronized captioning and audio descriptions when information is conveyed visually only. 
	Figures, images, animations, graphs, and audio files must have equivalent descriptions for screen reader users. Multimedia files require synchronized captioning and audio descriptions when information is conveyed visually only. 

	4.1. Images, Pictures, Objects etc 
	4.1. Images, Pictures, Objects etc 

	Overview Images, Pictures, Objects etc: ALL images that convey information must contain an alternate text attribute which can be read by screen readers.  Images that convey information must provide an equivalent description in the form of alternative text. If images contain text that conveys key information, the text must also be represented in the alternative text. For example the alternative text description for the DHS seal should be “Department of Homeland Security seal.”  Images that do not convey in
	Overview Images, Pictures, Objects etc: ALL images that convey information must contain an alternate text attribute which can be read by screen readers.  Images that convey information must provide an equivalent description in the form of alternative text. If images contain text that conveys key information, the text must also be represented in the alternative text. For example the alternative text description for the DHS seal should be “Department of Homeland Security seal.”  Images that do not convey in


	Artifact
	Images How to Test 
	Images How to Test 
	Images How to Test 
	Images How to Test 

	1 
	1 
	Use the Edit Object/TouchUp Object tool or view the properties of the tag associated with the image to verify that the image contains descriptive alternative text. 

	2 
	2 
	Visually identify complex images and determine if a reference to a more detailed text description is needed and has been provided. 

	3 
	3 
	Use the Content Pane to verify all decorative images are marked as <Artifact>. 


	Image Test Results 
	Image Test Results 
	Image Test Results 

	 If an image does not have an equivalent text description, mark Web 22 (a), FPC 31 (a) and (b) as NC.  If a decorative image is not marked as an <Artifact> or does not contain alternative text, mark 22 Web (a), FPC 31 (a) and (b) as NC.  If all images have an equivalent text description, mark Web 22 (a), FPC 31 (a) and (b) as C.  If decorative images are marked as <Artifacts> mark Web 22 (a), FPC 31 (a) and (b) as C.  If the document contains no images, mark Web 22 (a), FPC 31 (a) and (b) as NA. 
	 If an image does not have an equivalent text description, mark Web 22 (a), FPC 31 (a) and (b) as NC.  If a decorative image is not marked as an <Artifact> or does not contain alternative text, mark 22 Web (a), FPC 31 (a) and (b) as NC.  If all images have an equivalent text description, mark Web 22 (a), FPC 31 (a) and (b) as C.  If decorative images are marked as <Artifacts> mark Web 22 (a), FPC 31 (a) and (b) as C.  If the document contains no images, mark Web 22 (a), FPC 31 (a) and (b) as NA. 

	Applicable 508 Standards: 
	Applicable 508 Standards: 

	1194.22 Web (a) 1194.31 FPC (a) 1194.31 FPC (b) 
	1194.22 Web (a) 1194.31 FPC (a) 1194.31 FPC (b) 



	Artifact
	4.2. Audio‐only and Video‐only Files 
	4.2. Audio‐only and Video‐only Files 
	4.2. Audio‐only and Video‐only Files 

	Overview Audio or video only files must be accompanied with an accurate text equivalent. Audio files only play audible words or sounds and are considered non‐text interface elements. Video files that only display visual information are also considered non‐text interface elements. Both file types require equivalent text descriptions to describe the content. Usually, this is a transcript for audio‐only files. For video files with no sound, a description of the content is sufficient. Audio or Video Players Sof
	Overview Audio or video only files must be accompanied with an accurate text equivalent. Audio files only play audible words or sounds and are considered non‐text interface elements. Video files that only display visual information are also considered non‐text interface elements. Both file types require equivalent text descriptions to describe the content. Usually, this is a transcript for audio‐only files. For video files with no sound, a description of the content is sufficient. Audio or Video Players Sof


	Artifact
	Audio or Video How to Test 
	Audio or Video How to Test 
	Audio or Video How to Test 
	Audio or Video How to Test 

	1 
	1 
	Visually check to see if the document contains an audio file. If so verify it includes a text description that includes all relevant audio cues (ex: door bell rings, car honks, etc.)? If a text description is available, read the text description while listening to the audio file to ensure all necessary information is captured. 

	2 
	2 
	Visually check the document to see if it contains a video file. If so, verify that it includes a text description which includes all visual cues (ex: driver hands license to officer). If a text description is available, read the text description while watching the video file to ensure all necessary information is captured. 

	3 
	3 
	Verify that the target is tagged. 


	Audio or video Test Results 
	Audio or video Test Results 
	Audio or video Test Results 

	 If an audio interface element does not have an equivalent text transcript mark Web 22 (a), FPC 31 (c) and (d) as NC.  If video interface elements do not have an equivalent audio description mark Web 22 (a), FPC 31 (a), (b) as NC.  If the target for the audio and/or video file is not tagged mark Web 22 (d), FPC 31 (a), (b), (c) and (d) as NC.  If all audio and video interface elements have an equivalent text (transcript), or video‐description and the target for the audio and/or video file is tagged mark
	 If an audio interface element does not have an equivalent text transcript mark Web 22 (a), FPC 31 (c) and (d) as NC.  If video interface elements do not have an equivalent audio description mark Web 22 (a), FPC 31 (a), (b) as NC.  If the target for the audio and/or video file is not tagged mark Web 22 (d), FPC 31 (a), (b), (c) and (d) as NC.  If all audio and video interface elements have an equivalent text (transcript), or video‐description and the target for the audio and/or video file is tagged mark

	Applicable 508 Standards: 
	Applicable 508 Standards: 

	1194.22 Web (a) 1194.22 Web (d) 1194.31 FPC (a) 1194.31 FPC (b) 1194.31 FPC (c) 1194.31 FPC (d) 
	1194.22 Web (a) 1194.22 Web (d) 1194.31 FPC (a) 1194.31 FPC (b) 1194.31 FPC (c) 1194.31 FPC (d) 



	Artifact
	4.3. Multimedia 
	4.3. Multimedia 
	4.3. Multimedia 

	Overview Multimedia is the combination of more than one time‐based medium including visuals and sound to match at the same rate and exactly together to convey information and instruction. All multimedia presentations must contain captioning for auditory information and audio descriptions for information conveyed visually only. Multimedia Players Multimedia players must meet 1194.21 Software standards. For assistance testing the multimedia player for Section 508 compliance contact the Accessibility Helpdesk 
	Overview Multimedia is the combination of more than one time‐based medium including visuals and sound to match at the same rate and exactly together to convey information and instruction. All multimedia presentations must contain captioning for auditory information and audio descriptions for information conveyed visually only. Multimedia Players Multimedia players must meet 1194.21 Software standards. For assistance testing the multimedia player for Section 508 compliance contact the Accessibility Helpdesk 


	Multimedia How to Test: 
	Multimedia How to Test: 
	Visually inspect the document for multimedia. If the document contains multimedia, manually check the multimedia for captioning that is synchronized with the audible sounds and dialogue. Descriptions of important sounds must be included in captions. If there are visual actions necessary for comprehension, check that they are adequately described in the audio track. All relevant audible and visual information from the multimedia should be available if the speakers are off or if the monitor is off. 
	Multimedia Test Results 
	Multimedia Test Results 
	Multimedia Test Results 

	 If there are no synchronized captions, mark Web 22 (b) and 24 (c) as NC.  If audio descriptions are needed and not provided, mark Web 22 (b) and 24 (d) as NC.  If the multimedia includes synchronized captions and audio descriptions, mark Web 22 (b), 24 (c) and (d) as C.  If there is no multimedia, mark Web 22 (b), 24 (c) and (d) as NA. 
	 If there are no synchronized captions, mark Web 22 (b) and 24 (c) as NC.  If audio descriptions are needed and not provided, mark Web 22 (b) and 24 (d) as NC.  If the multimedia includes synchronized captions and audio descriptions, mark Web 22 (b), 24 (c) and (d) as C.  If there is no multimedia, mark Web 22 (b), 24 (c) and (d) as NA. 

	Applicable 508 Standards: 
	Applicable 508 Standards: 

	1194.22 Web (b) 1194.24 Multimedia (c) 1194.24 Multimedia (d) 
	1194.22 Web (b) 1194.24 Multimedia (c) 1194.24 Multimedia (d) 



	Artifact
	PDF.Document.Accessibility.Test.Process. 
	PDF.Document.Accessibility.Test.Process. 
	PDF.Document.Accessibility.Test.Process. 
	PDF.Document.Accessibility.Test.Process. 
	PDF.Document.Accessibility.Test.Process. 

	PDF.Document.Accessibility.Test.Process. 


	5. Security Overview Although security settings can be set to protect a document from being modified, security settings must never prevent assistive technology from being able to read a document. Security Test Results  If Content Copying for Accessibility is not allowed mark FPC 31 (a) and (b) as NC.  If Content Copying for Accessibility is allowed mark FPC 31 (a) and (b) as C. Security How to Test 1 Go to File>Properties>Security> and check to see if Content Copying for Accessibility is “Allowed”. Applic
	Artifact
	6. Accessible Version Overview Alternative versions for accessibility are only permitted when the primary content cannot be made compliant. Check for a Text only or alternative version of content:  If the primary content is not compliant but can be made compliant, then it must be remediated.  Text only files must be maintained and updated with the primary content. Note: PDFs created via Flash Paper cannot be made compliant. Decision charts may require a text alternative. Accessible Version How to Test 1 M
	Artifact

	Adobe Acrobat Accessibility Full Check Tool 
	Adobe Acrobat Accessibility Full Check Tool 
	The Accessibility Full Check tool can help to identify areas of a document that may be in conflict with Adobe’s interpretations of accessibility guidelines, such as the document lacking actual text, a specified language and having security settings that prevents access by screen readers. However, the tool does not check documents against all accessibility criteria. Therefore, Acrobat’s Accessibility Full Check tool must be used in conjunction with a manual testing process to correctly evaluate PDFs for Sect
	How to Set Up Accessibility Full Check Tool 
	How to Set Up Accessibility Full Check Tool 
	How to Set Up Accessibility Full Check Tool 

	1. 
	1. 
	1. 
	Go to Tools>Accessibility>Full Check to access the Accessibility Full check tool. 

	2. 
	2. 
	2. 
	2. 
	Under Reports and Comments Options check 

	a. 
	a. 
	a. 
	Create Accessibility Report 

	b. 
	b. 
	Include repair hints in Accessibility Report 



	3. 
	3. 
	3. 
	Under Page Range select 

	a. All pages in document 


	4. 
	4. 
	4. 
	4. 
	Under Checking Options select 


	a. 
	a. 
	a. 
	a. 
	(Name) Acrobat PDF 

	b. 
	b. 
	Alternative descriptions are provided 

	c. 
	c. 
	Text language is specified 

	d. 
	d. 
	Reliable character encoding is provided 


	e. 
	e. 
	All content is contained in the document structure 

	f. 
	f. 
	f. 
	All form fields have descriptions 

	g. 
	g. 
	Tab order is consistent with the structure order 

	h. 
	h. 
	List and Table structure is correct 




	5. 
	5. 
	Select Start Checking to run the Accessibility Full Check tool 



	What does the Accessibility Full Check Tool Do? 
	What does the Accessibility Full Check Tool Do? 
	What does the Accessibility Full Check Tool Do? 
	This tool allows users to quickly identify the following issues: 
	 If the document does or does not contain tags 
	 If a language has been set in the document’s properties 
	 If content is not tagged 

	 If the font in the document is related to reliable character encoding 
	 If the tab order is consistent with the documents structure. 
	 If alternative text has been applied to images 
	 If alternative text has been applied to images 
	 If tooltips have been applied to form fields 
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	Artifact
	PDF.Document.Accessibility.Test.Process. 
	PDF.Document.Accessibility.Test.Process. 
	 If list and tables have a correct tag structure 


	What are the limitations of the Full Check Tool? 
	What are the limitations of the Full Check Tool? 
	What are the limitations of the Full Check Tool? 

	Elements that the tool cannot accurately evaluate for Section 508 compliance includes but is not limited to: 
	 Validating if all of the content is contained in the structure tree and follows a logical Reading and Tab order  Validating if Color alone is not being used to convey information  Validating if images contain accurate alternative text descriptions  Validating if form fields are associated with proper tooltips 
	Additionally, the Accessibility Full Check tool may also generate Acrobat structure errors that are unrelated to Section 508. These errors include, but are not limited to: 
	 Unspecified Unicode‐Acrobat does not recognize the font type used in the document  Untagged Annotations‐Meta data in Microsoft Office was not cleared before converting the document into a PDF  Inaccessible Link‐At this time it is unknown why Acrobat generates this error 
	Artifact
	PDF.Document.Accessibility.Test.Process. 
	PDF.Document.Accessibility.Test.Process. 



	List of Acrobat Full Check Errors 
	List of Acrobat Full Check Errors 
	List of Acrobat Full Check Errors 

	Source: The information located under the “Meaning” column was taken from the Social Security Administration’s draft guidance for testing PDFs, April 2012. Used with permission. 
	Full Check Error 
	Full Check Error 

	Meaning 
	508 Reference 
	Figure element(s) 
	Figure element(s) 
	Figure element(s) 
	Figures (pictures, images) do not have any alternate text added. 
	36 CFR 1194.22(a) 

	with no alternate text 
	with no alternate text 
	Note: This check does not account for the following, which must be checked manually: 
	36 CFR 1194.31(a) 

	TR
	TH
	Artifact

	1. Images that contain alternate text that is insufficient for a reader to comprehend the purpose of the image, and/or alternate text that is incorrect, or not helpful in the context of the surrounding image. 2. Images that contain paths or filenames in place of correct alternate text. 3. Images that are part of the background (i.e., purposefully have no alternate text) will be incorrectly flagged as errors by this test. 
	36 CFR 1194.31(b) 

	All of the text on this page lacks a language specification 
	All of the text on this page lacks a language specification 
	The default language has not been set in the document properties. Note: This checks only that there is a language specified; it does not check whether the correct language is specified. 
	36 CFR 1194.31(a) 36 CFR 1194.31(b) 

	Word(s) that contain 
	Word(s) that contain 
	This is error occurs when non‐standard fonts are used, either for 
	36 CFR 1194.31(a) 

	characters with no 
	characters with no 
	the whole document, chunks of text, or bullet characters. Screen 

	reliable mapping to 
	reliable mapping to 
	reader software will typically not pronounce these correctly. 
	36 CFR 1194.31(b) 

	Unicode 
	Unicode 
	Note: The fonts that are erroneous can be easily inspected, as errors are clearly annotated in the Document Properties Panel (Fonts tab). 

	Element(s) that are 
	Element(s) that are 
	This error means there are elements on the page for which 
	36 CFR 1194.22(d) 

	not contained within 
	not contained within 
	there is no corresponding tag. 

	the structure tree 
	the structure tree 
	This error usually occurs if an element has been added to an existing PDF using Acrobat’s editing tools (e.g., a link or an image is added). In the editing process, tags are not automatically added. 


	Artifact
	PDF.Document.Accessibility.Test.Process. 
	PDF.Document.Accessibility.Test.Process. 
	PDF.Document.Accessibility.Test.Process. 
	PDF.Document.Accessibility.Test.Process. 

	Full Check Error 

	Meaning 
	508 Reference 
	None of the 
	None of the 
	None of the 
	This error usually occurs if a comment has been added to an 
	36 CFR 1194.22(d) 

	comments or other 
	comments or other 
	existing PDF using Acrobat’s editing tools. In the editing process, 

	types of annotations 
	types of annotations 
	tags are not automatically added. 

	on this page are contained in the 
	on this page are contained in the 
	Note: If in running the ‘Accessibility Full Check’ dialog box the reviewer has selected ‘Create comments in the document’, and 

	structure tree 
	structure tree 
	then the check is run a subsequent time, the checker’s own comments will generate this error. If this error occurs, but the document is intended for an audience that is relying on editorial comments and tracking for its work, then the error can be ignored. However, if there are Assistive Technology users working with the document, then additional verification tasks may be needed to determine whether the comments and other annotations are accessible. 

	Form field(s) with no description 
	Form field(s) with no description 
	This error will only occur when form fields are used. 
	36 CFR 1194.22(n) 

	Page(s) with tab 
	Page(s) with tab 
	This error will only occur when form fields are used. 
	36 CFR 1194.31(a) 

	order that may be 
	order that may be 

	inconsistent with the 
	inconsistent with the 
	36 CFR 1194.31(b) 

	structure order 
	structure order 

	Tab order may be inconsistent with the structure order 
	Tab order may be inconsistent with the structure order 
	This error occurs when the Page Tab Order is set to something other than “Use Document Structure”’ 
	36 CFR 1194.31(a) 36 CFR 1194.31(b) 

	List tags/item(s) with 
	List tags/item(s) with 
	The correct list tagging structure has not been used. 
	36 CFR 1194.22(d) 

	no parent(s) 
	no parent(s) 
	Note: This automated test does not check for chunks of text that should be marked as lists but which is actually formatted as regular paragraph text. Lists formatted as regular paragraph text must be checked manually. 

	TH or TD element(s) 
	TH or TD element(s) 
	This error occurs if table tags have been edited incorrectly in 
	36 CFR 1194.22(d) 

	with no TR parent 
	with no TR parent 
	Acrobat (e.g., moved around in the tag tree, where they are outside of the normal table tag structure). Note: This automated test does not check for tables that have no tags, have incorrect tags, or tables that are rendered as images. Tables that are irregularly formatted, and tables that are not tagged, must be checked manually. 

	Other errors 
	Other errors 
	Other errors may be generated. Follow on‐screen instructions for more details. Note: The above lists the common errors that can be generated by the Adobe Acrobat X Accessibility Checker at the time of writing. Future software updates may alter the checker’s results. 
	N/A 


	Artifact

	Standard Acrobat PDF Tags 
	Standard Acrobat PDF Tags 
	Standard Acrobat PDF Tags 

	Source: Excerpted from Adobe Systems, Inc. (2011) Using Adobe Acrobat X Pro, (pp.301‐303), Adobe Systems Incorporated, 345 Park Avenue, San Jose, California 95110, USA. Available: 
	http://help.adobe.com/en_US/acrobat/pro/using/acrobat_X_pro_help.pdf 
	http://help.adobe.com/en_US/acrobat/pro/using/acrobat_X_pro_help.pdf 
	http://help.adobe.com/en_US/acrobat/pro/using/acrobat_X_pro_help.pdf 


	Container Elements 
	Container Elements 
	Container Elements 

	Container elements are the highest level of element and provide hierarchical grouping for other block‐level 
	elements. 
	elements. 
	Document 
	Document 
	Document element. The root element of a document’s tag tree. 


	Part 
	Part 
	Part 

	Part element. A large division of a document; may group smaller units of content together, such as division elements, article elements, or section elements. 
	Div 
	Div 

	Division element. A generic block‐level element or group of block‐level elements. 
	Art 
	Art 

	Article element. A self‐contained body of text considered to be a single narrative. 

	Sect 
	Sect 
	Sect 

	Section element. A general container element type, comparable to Division (DIV Class="Sect") in HTML, which is usually a component of a part element or an article element. 


	Heading and Paragraph Elements 
	Heading and Paragraph Elements 
	Heading and Paragraph Elements 

	Heading and paragraph elements are paragraph‐like, block‐level elements that include specific level heading and generic paragraph (P) tags. A heading (H) element should appear as the first child of any higher‐level division. Six levels of headings (H1 to H6) are available for applications that don’t hierarchically nest sections. 
	Label and List Elements 
	Label and List Elements 

	Label and list elements are block‐level elements used for structuring lists. 
	L 
	L 

	List element. Any sequence of items of similar meaning or other relevance; immediate child elements should be list item elements. 
	LI 
	LI 

	List item element. Any one member of a list; may have a label element (optional) and a list body element (required) as a child. 
	Artifact
	PDF.Document.Accessibility.Test.Process. 
	PDF.Document.Accessibility.Test.Process. 
	LBL 

	Label element. A bullet, name, or number that identifies and distinguishes an element from others in the same list. 
	LBody 
	LBody 
	List item body element. The descriptive content of a list item. 


	Special Text Elements 
	Special Text Elements 
	Special Text Elements 

	Special text elements identify text that isn’t used as a generic paragraph (P). 
	BlockQuote 
	BlockQuote 
	BlockQuote 

	Block quote element. One or more paragraphs of text attributed to someone other than the author of the immediate surrounding text. 

	Caption 
	Caption 
	Caption 

	Caption element. A brief portion of text that describes a table or a figure. 

	Index 
	Index 
	Index 

	Index element. A sequence of entries that contain identifying text and reference elements that point out the occurrence of the text in the main body of the document. 
	TOC 
	TOC 

	Table of contents element. An element that contains a structured list of items and labels identifying those items; has its own discrete hierarchy. 

	TOCI 
	TOCI 
	TOCI 

	Table of contents item element. An item contained in a list associated with a table of contents element. 


	Table Elements 
	Table Elements 
	Table Elements 
	Table elements are special elements for structuring tables. 
	Table 

	Table element. A two‐dimensional arrangement of data or text cells that contains table row elements as child elements and may have a caption element as its first or last child element. 
	TR 
	TR 

	Table row element. One row of headings or data in a table; may contain table header cell elements and table data cell elements. 
	TD 
	TD 

	Table data cell element. A table cell that contains nonheader data. 
	TH 
	TH 

	Table header cell element. A table cell that contains header text or data describing one or more rows or columns of a table. 
	Artifact
	PDF.Document.Accessibility.Test.Process. 
	PDF.Document.Accessibility.Test.Process. 


	Inline‐level Elements 
	Inline‐level Elements 
	Inline‐level Elements 

	Inline‐level elements identify a span of text that has specific formatting or behavior. They are differentiated from block‐level elements. Inline‐level elements may be contained in or contain block‐level elements. 
	BibEntry 
	BibEntry 
	BibEntry 

	Bibliography entry element. A description of where some cited information may be found. 

	Quote 
	Quote 
	Quote 

	Quote entry element. An inline portion of text that is attributed to someone other than the author of the text surrounding it; different from a block quote, which is a whole paragraph or multiple paragraphs, as opposed to inline text. 

	Span 
	Span 
	Span 

	Span entry element. Any inline segment of text; commonly used to delimit text that is associated with a set of styling properties. 


	Special Inline‐level Elements 
	Special Inline‐level Elements 
	Special Inline‐level Elements 

	Similar to inline‐level elements, special inline‐level elements describe an inline portion of text that has special formatting or behavior. 
	Code 
	Code 

	Code entry element. Computer program text embedded within a document. 
	Figure 
	Figure 
	Figure 

	Figure entry element. A graphic or graphic representation associated with text. 

	Form 
	Form 
	Form 

	Form entry element. A PDF form annotation that can be or has been filled out. 
	Formula 
	Formula 
	Formula entry element. A mathematical formula. 


	Link 
	Link 
	Link 

	Link entry element. A hyperlink that is embedded within a document. The target can be in the same document, in another PDF document, or on a website. 

	Note 
	Note 
	Note 

	Note entry element. Explanatory text or documentation, such as a footnote or endnote, that is referred to in the main body of text. 
	Reference 
	Reference 

	Reference entry element. A citation to text or data that is found elsewhere in the document. 
	Artifact
	PDF.Document.Accessibility.Test.Process. 
	PDF.Document.Accessibility.Test.Process. 




	Section 508 Standards Mapped to DHS PDF Document Test Process 
	Section 508 Standards Mapped to DHS PDF Document Test Process 
	Each Section 508 standard is mapped to the DHS PDF Testing Process for testers who are more familiar with the alphabetical approach. Only the standards that are applicable to PDFs are listed. For a full list of the Section 508 standards of the Rehabilitation Act of 1973, as amended (29 U.S.C., go to 
	Seciton 508 standards () 
	http://section508.gov/index.cfm?fuseAction=stdsdoc


	1194.22 Web 
	1194.22 Web 
	1194.22 Web 

	Standard 
	Standard 
	Standard 
	Test Process 

	(a) Images 
	(a) Images 
	A text equivalent for every non‐text element shall be provided (e.g., via "alt", "longdesc", or in element content). 

	(b) Multimedia Presentations 
	(b) Multimedia Presentations 
	Equivalent alternatives for any multimedia presentation shall be synchronized with the presentation. 

	(c) Color 
	(c) Color 
	Web pages shall be designed so that all information conveyed with color is also available without color, for example from context or markup. 

	(d) Readability 
	(d) Readability 
	Original Access‐Board standard: Documents shall be organized so they are readable without requiring an associated style sheet. Modified for PDFs: The Content and Tag views should be consistent with the physical view, meaning that the document should be read from the structure without requiring the physical view. Note: This modified language was provided by NetCentric. 

	(g) Data Table 
	(g) Data Table 
	Row and column headers shall be identified for data tables. 

	(h) Data Tables with multiple headers 
	(h) Data Tables with multiple headers 
	Markup shall be used to associate data cells and header cells for data tables that have two or more logical levels of row or column headers. 

	(k) Text‐Only Alternative 
	(k) Text‐Only Alternative 
	A text‐only page, with equivalent information or functionality, shall be provided to make a web site comply with the provisions of these standards, when compliance cannot be accomplished in any other way. The content of the text‐only page shall be updated whenever the primary page changes. 

	(n) Electronic Forms 
	(n) Electronic Forms 
	When electronic forms are designed to be completed on‐line, the form shall allow people using assistive technology to access the information, field elements, and functionality required for completion and submission of the form, including all directions and cues. 


	Artifact
	PDF.Document.Accessibility.Test.Process. 
	PDF.Document.Accessibility.Test.Process. 
	1194.24 Multimedia 

	Standard 
	Standard 
	Standard 
	Test Process 

	(c) Captioning 
	(c) Captioning 
	Multimedia that contains speech or other audio information necessary for the comprehension of the content shall be open or closed captioned and the captioning must be synchronized and spelled correctly. 

	(d) Audio Description 
	(d) Audio Description 
	All training and informational video and multimedia productions which support the agency's mission, regardless of format, that contain visual information necessary for the comprehension of the content, shall be audio described. 


	1194.31 Functional Performance 
	1194.31 Functional Performance 

	Standard 
	Standard 
	Standard 
	Test Process 

	(a) Blind 
	(a) Blind 
	At least one mode of operation and information retrieval or support for assistive technology shall be provided that does not require: 

	(b)Low Vision 
	(b)Low Vision 
	At least one mode of operation and information retrieval or support for assistive technology shall be provided that does not require: 

	(c) Deaf 
	(c) Deaf 
	At least one mode of operation and information retrieval or support for assistive technology shall be provided that does not require: 

	(d)Hard of Hearing 
	(d)Hard of Hearing 
	At least one mode of operation and information retrieval or support for assistive technology shall be provided that does not require: 

	(f) Mobility 
	(f) Mobility 
	At least one mode of operation and information retrieval that does not require fine motor control or simultaneous actions and that is operable with limited reach and strength shall be provided. 









